Autostart von TeamDrive 4.3 funktioniert nicht unter KDE

General news about the Linux Version of TeamDrive (Gerne auch auf Deutsch)

Autostart von TeamDrive 4.3 funktioniert nicht unter KDE

Postby locdoc01 » 29 Dec 2016, 18:48

Hallo, ich bin neu bei TeamDrive. Ich habe den Client in der Version 4.3.1 erfolgreich auf einem Linux Mint 18 Mate und auf einem Linux Mint 18 KDE installiert. Auf beiden Systemen läuft alles einwandfrei, mit einer Ausnahme:
Auf dem KDE-System startet der Client nicht automatisch, obwohl es in den TeamDrive-Einstellungen aktiviert ist und auch in den Autostart-Einstellungen von KDE richtig eingetragen wurde (/home/user/TeamDrive/TeamDrive" "autostart")
Wenn ich das TeamDrive-Script manuell starte, läuft es.
Kann mir jemand nen Tip geben, wie ich den Autostart reparieren kann?

Danke im Voraus!
locdoc01
locdoc01
 
Posts: 1
Joined: 29 Dec 2016, 18:29

Re: Autostart von TeamDrive 4.3 funktioniert nicht unter KDE

Postby Goldbär » 09 Mar 2017, 19:36

Das selbe Problem hatte ich mit KDE Plasma 5 bei OpenSuse.

Teamdrive habe ich in das Verzeichnis $HOME/sw/TeamDrive installiert.
Im Ordner $HOME/bin habe ich ein Skript mit dem Dateinamen "TeamDriveAutostart.sh" und folgendem Inhalt erzeugt:
Code: Select all
#!/bin/bash
### TeamDrive starten
COMMAND=${HOME}/sw/TeamDrive/TeamDrive.bin
WARTEZEIT=90
OPTIONS="--teamdrive-home ${HOME}/sw/TeamDrive --spaces-path ${HOME}/Spaces --backup-path ${HOME}/Spaces/Backups"

if [ -e ${COMMAND} ]
then
    # TeamDrive existiert.
    sleep ${WARTEZEIT}
    # In das TeamDrive Programmverzeichnis wechseln
    cd ${COMMAND%/*}
   
    ### Programm direkt aufrufen, mit Skript funktioniert das nicht
    export LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH}
    exec ${COMMAND} ${OPTIONS}
else
    echo "Das Programm \"${COMMAND}\" gibt es nicht."
    exit 1
fi
exit 0

Die Skriptdatei als ausführbar kennzeichnen. Bei den Einstellungen für die Programmoptionen OPTIONS="..." ist "--spaces-path" und "--backup-path" eventuell nicht notwendig.
In der Zeile "WARTEZEIT=90" kannst du natürlich auch eine andere Sekundenzahl eintragen.

Wenn ich dieses Skript in KDE Systemeinstellungen / Autostart eintrage, funktioniert es bei mir.
Goldbär
 
Posts: 1
Joined: 09 Mar 2017, 19:13


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron