After update to 4.7.2 (3014) Client does not start anymore

Questions and information regarding the Linux desktop client - Fragen und Informationen zum Linux Desktop-Client

After update to 4.7.2 (3014) Client does not start anymore

Postby BjoernSt » 26 Oct 2021, 12:24

Hi all,
I have just updated my TD client on Linux (Debian 10) from 4.6 (don't remember the minor version and build number anymore) to the latest version 4.7.2 (3014). I have installed the client over the previous one in the existing folder (/opt/teamdrive).
When I tried to start the client I am presented the error message
"Cannot access the Database: the database was created by version 4.7.3014 of Teamdrive. Upgrade is required."

TD-update-broken.png
Screenshot


What does this all mean and how can I fix it? Any help is appreciated !

Best regards
Björn
BjoernSt
 
Posts: 3
Joined: 26 Oct 2021, 12:09

Re: After update to 4.7.2 (3014) Client does not start anymo

Postby Kenneth » 28 Oct 2021, 10:39

Right now it seems like TeamDrive is installed in two different locations and the incorrect installation is being started. Please send a support ticket to support@teamdrive.com, make reference to this forum post (provide us with the link) and provide us with your phone number so we can call you for a short remote session to resolve the issue. For the remote session you will need our remote support client: https://get.teamviewer.com/6e7sjtf
Kenneth
 
Posts: 1254
Joined: 29 Aug 2012, 15:11

Re: After update to 4.7.2 (3014) Client does not start anymo

Postby BjoernSt » 02 Nov 2021, 18:59

Hi Kenneth,
many thanks for your answer. I doubt there are two installations of Teamdrive and that an incorrect installation is being started.

The old installation was in path "/opt/teamdrive". The installer for 4.7.3 wanted to install into "opt/TeamDrive" and I changed the install directory to existing path in order to not have two different installations. May be, installing a new client over an existing one does not work as one would expect it to work.

Here is some info from my system:
01_which_td.png


02_less_td.png
02_less_td.png (11.22 KiB) Viewed 119 times


03_ls_opt.png


Since I am running Teamdrive in an Linux App VM inside Qubes OS which comes with an own GUI layer I am not sure whether Teamviewer would work as expected. Thus I would like to try some manual steps myself first. I will try to uninstall using the uninstaller in /opt/teamdrive and make a fresh install on a hopefully clean system then. If this still fails, I would open a ticket with the support team.

Best regards,
Björn
BjoernSt
 
Posts: 3
Joined: 26 Oct 2021, 12:09

Re: After update to 4.7.2 (3014) Client does not start anymo

Postby BjoernSt » 02 Nov 2021, 19:48

Hi Kenneth, all,
and in the end it was that easy! I just had to run uninstall from the the /opt/teamdrive folder and manually clean up the left overs. There was a lib folder in /opt/teamdrive with some older libs from 2019 that survived the uninstall. May be these libs caused the trouble when I have simply installed the new version over the old one.

After a fresh install of the TD client everything seems to be fine again.

Best regards
Björn
BjoernSt
 
Posts: 3
Joined: 26 Oct 2021, 12:09


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron