Problem when starting TD PS after install on Lenny

Problem when starting TD PS after install on Lenny

Postby guti » 21 Jan 2011, 13:20

Hi all,

I just downloaded, installed and configured the PersonalServer on Lenny. When I try to run ./tdpsd I get the following error message:

Code: Select all
./tdpsd: /lib/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by ./tdpsd)


The system is Debian Lenny 32 bit, completely up to date.
guti
 
Posts: 75
Joined: 24 Apr 2009, 12:48

Re: Problem when starting TD PS after install on Lenny

Postby preisl » 23 Jan 2011, 12:36

Hi,

see: viewtopic.php?f=18&t=1156

I guess Lenny is not using libc 2.8 yet ... you can check that by executing

Code: Select all
dpkg -l | grep libc6


regards,

Martin
preisl
 
Posts: 22
Joined: 16 Sep 2010, 15:59
Location: Austria / Klagenfurt

Re: Problem when starting TD PS after install on Lenny

Postby guti » 23 Jan 2011, 14:39

You're right:

Code: Select all
ii  libc6                             2.7-18lenny7               GNU C Library: Shared libraries
ii  libc6-dev                         2.7-18lenny7               GNU C Library: Development Libraries and Hea
ii  libc6-i686                        2.7-18lenny7               GNU C Library: Shared libraries [i686 optimi


What can I do now? I need the Personal Server :-)

BRgds
guti
 
Posts: 75
Joined: 24 Apr 2009, 12:48

Re: Problem when starting TD PS after install on Lenny

Postby preisl » 23 Jan 2011, 22:52

According to the answer on my original question, the TeamDrive guys plan to support older libc versions at the beginning of 2011 ... not sure what exact timeframe that is.

regards,

Martin
preisl
 
Posts: 22
Joined: 16 Sep 2010, 15:59
Location: Austria / Klagenfurt

Re: Problem when starting TD PS after install on Lenny

Postby guti » 24 Jan 2011, 12:04

@Teamdrive-Team: Could you let us know a bit more about this? Will Lenny be supported and will this still happen in January or am I better off looking for a different solution?

I could also update libc6 only from Debian stable to testing, which I assume includes a version >=2.8, but I'm unsure about what other effects that could have on the whole system.
guti
 
Posts: 75
Joined: 24 Apr 2009, 12:48

Re: Problem when starting TD PS after install on Lenny

Postby Detlef Schmuck » 26 Jan 2011, 19:59

We are working on a solution with our build system. Unfortunately this is a more complex job than we thought.
A realistic date would be March that we will support the current Debian build.

You TeamDrive team
Detlef Schmuck
TeamDrive Team Member
 
Posts: 628
Joined: 07 Jul 2008, 19:20

Re: Problem when starting TD PS after install on Lenny

Postby Beaker » 08 Mar 2011, 09:28

Hi,

is there any chance to get a realistic date of a release that works on Debian Lenny? I mean not "...released in March" or something.

Please let me/us know.
Beaker
 
Posts: 8
Joined: 08 Mar 2011, 09:23

Re: Problem when starting TD PS after install on Lenny

Postby guti » 08 Mar 2011, 12:14

now that Squeeze is out I guess the problem is solved, right? Does the PS work currectly in Squeeze?
guti
 
Posts: 75
Joined: 24 Apr 2009, 12:48

Re: Problem when starting TD PS after install on Lenny

Postby Beaker » 08 Mar 2011, 15:13

Mmmh I don't if TDPS is running correct on "Squeeze" but the Problem is i have Lenny installed on my V-Server and i don't want to change the whole system for only one program. I hope for the Solution announced here that should come in this month.
Beaker
 
Posts: 8
Joined: 08 Mar 2011, 09:23

Re: Problem when starting TD PS after install on Lenny

Postby guti » 08 Mar 2011, 15:20

I know, but now that Squeeze is debian stable you will have to upgrade sooner or later anyways...
(ok, if everything else runs fine I would also prefer waiting another year)
guti
 
Posts: 75
Joined: 24 Apr 2009, 12:48


Return to TeamDrive Personal Server

Who is online

Users browsing this forum: No registered users and 3 guests

cron