Update auf Agent 4.6.1: Administration nur noch mit Edge/IE

Update auf Agent 4.6.1: Administration nur noch mit Edge/IE

Postby atrottmann » 12 Jul 2018, 11:02

Ich schätze es sehr, dass Sie einen TeamDrive Agent bereitstellen, der es ermöglicht, auf Linux-Servern "headless" eine TeamDrive-Synchronisation bereitzustellen!

Wir haben einige Monate lang den TeamDrive Agent aus teamdrive_agent_4.5.5.1838_el6.x86_64.tar.gz erfolgreich benutzt, und sein Administrations-Webinterface problemlos mit verschiedenen Browsern (unter anderen Chrome auf Linux) bedient.

Nach einem Update auf teamdrive_agent_4.6.1.2027_el6.x86_64.tar.gz funktioniert das Administrations-Webinterface aber nur noch mit Edge und IE.

Hier die Symptome:

Mit Chrome und Firefox (neueste Versionen) auf Linux und Windows:

Zugriff auf Webinterface gibt ein "ordentliches" Login-Formular. Wenn man aber mit korrektem Benutzernamen und Passwort einloggt, erscheint gleich wieder sofort das Loginformular. Wenn man ein falsches Passwort eingibt, erscheint eine entsprechende Meldung.

Mit Internet Explorer und Edge (neueste Versionen) auf Windows 7 (nur IE) und Windows 10 (IE und Edge): Der Login und die Benutzung klappt

Es wäre super, wenn das Interface wieder mit Chrome und Firefox funktionieren würde.
atrottmann
 
Posts: 4
Joined: 03 Aug 2016, 14:41

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby Kenneth » 18 Jul 2018, 09:07

Versuchen Sie bitte die 4.6.2.2109 version von der Webseite.
Kenneth
 
Posts: 961
Joined: 29 Aug 2012, 15:11

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby atrottmann » 18 Jul 2018, 10:02

Das ändert leider nichts; das Verhalten ist immer noch das gleiche.

Ich habe es nun auch mit Safari auf macOS versucht, was das gleiche Resultat ergibt.
atrottmann
 
Posts: 4
Joined: 03 Aug 2016, 14:41

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby Kenneth » 23 Jul 2018, 11:38

Dieses Problem konnten wir leider nicht reproduzieren.

Versuchen Sie sich einzuloggen während der Web-Konsole offen ist (bei Firefox kann man die Web-Konsole öffnen, wenn Sie F12 tippen und auf den "Konsole" Tab klicken. Es kann sein, dass die Entwickler-Optionen aktivieret werden müssen). Dabei möchten Sie auch schauen, ob Sie Javascript Fehlermeldungen sehen.
Kenneth
 
Posts: 961
Joined: 29 Aug 2012, 15:11

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby atrottmann » 24 Jul 2018, 15:24

Vielen Dank für diesen Hinweis!

Bei Verwendung von Chrome (hier auf Linux) erhalte ich gleich nach dem Klicken auf "Login":

TypeError: Cannot read property 'error' of undefined
at app.js:2
at i (app.js:7)
at app.js:7
at n.$digest (app.js:7)
at n.$apply (app.js:7)
at g (app.js:7)
at r (app.js:7)
at XMLHttpRequest.w.onload (app.js:7) "Possibly unhandled rejection: {}"


app.js:2 ist eine sehr lange Zeile im "minifizierten" Javascript. Chrome hat eine Funktion, um es lesbarer zu formatieren, was dann ergibt, dass der Fehler in folgendem Code auftaucht:

Code: Select all
                d.login(a.formData.username, a.formData.password).then(function() {
                    d.loadStartPage()
                })["catch"](function(b) {
                    32 == b.data.error ? a.shopUrl = b.data.error_message : 53 == b.data.error ? (a.emailSent = !0,
                    a.waitingForActivation || (a.waitingForActivation = !0,
                    f())) : a.errorMessage = b.data.error_message
                })


d.H. offenbar wird die "catch" Klausel aufgerufen, und wenn dann "32 == b.data.error" abgefragt wird, ist offenbar b.data undefined.

Der letzte erfolgte Netzwerkzugriff ist ein XMLHttpRequest nach https://hostname-unseres-teamdrive-servers:4443/login mit dem Payload {username: "...", password: "..."} (wobei natürlich eine korrekte Kombination aus Username und Passwort drin ist). Die Antwort, die drauf kommt, erscheint sinnvoll:

{ "address" : { "email" : "...", "icon" : "self", "id" : 1, "initials" : "...", "name" : "...", "profile" : { "email" : "...", "mobile" : "", "phone" : "" } }, "apiUrl" : "/", "initials" : "...", "isLocal" : true, "isLoginRequired" : false, "username" : "...", "websocketUrl" : ":1" }

(überall da wo "..." steht, standen sinnvolle / korrekte Informationen über den verwendeten Benutzer)


Mit Firefox habe ich ein ähnliches Bild: Die Javascript-Fehlermeldung nach dem Login ist:

TypeError: b.data is null
Stack-Trace:
[17]</b.exports</a.login/<@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:2:313
i@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:18856
k/<@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:19302
Lc/this.$get</n.prototype.$digest@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:25131
Lc/this.$get</n.prototype.$apply@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:27105
g@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:924
r@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:3495
Wb/</w.onload@https://hostname-unseres-teamdrive-servers:4443/scripts/app.js:7:3919
Possibly unhandled rejection: {} app.js:7:12524


Auch hier ist das letzte was ich auf dem Netzwerk sehe ein Post nach /login mit korrekt aussehenden Eingabe- und Ausgabeparametern.
atrottmann
 
Posts: 4
Joined: 03 Aug 2016, 14:41

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby Kenneth » 25 Jul 2018, 10:56

Welche Versionen von Chrome und Firefox Sie benutzen wäre für uns auch interessant.
Kenneth
 
Posts: 961
Joined: 29 Aug 2012, 15:11

Re: Update auf Agent 4.6.1: Administration nur noch mit Edge

Postby atrottmann » 25 Jul 2018, 18:04

Ich habe die jeweils aktuellste Version auf Linux, macOS und Windows getestet.

Darunter sind:

Chrome auf Linux, 67.0.3396.99 (Offizieller Build) (64-Bit)
Firefox auf Linux, aktuelle ESR-Version von Debian Stable: 52.9.0 (64-Bit)

Chrome auf Windows 7, 67.0.3396.99 (Offizieller Build) (64-Bit)
Chrome auf Windows 7, 68.0.3440.75 (Offizieller Build) (64-Bit)
Firefox auf Windows 7, 61.0.1 (64-Bit)

Chrome auf macOS High Sierra, 67.0.3396.99 (Offizieller Build) (64-Bit)
Chrome auf macOS High Sierra, 68.0.3440.75 (Offizieller Build) (64-Bit)
Firefox auf macOS High Sierra, 61.0.1 (64-Bit)
Safari auf macOS High Sierra, 11.1.1 (13605.2.8)


Das Verhalten ist überall das gleiche.

Mein Teamdrive Agent ist wie folgt konfiguriert, falls das eine Rolle spielt:

[Settings]
default-server=
http-api-certificate=/etc/ssl/certs/certificate.crt
http-api-port=0.0.0.0:4443
http-api-private-key=/etc/ssl/private/certificate.key
http-api-type=ssl
language=de-DE

Das verwendete Zertifikat ist von LetsEncrypt und wird von den verwendeten Browsern akzeptiert.
atrottmann
 
Posts: 4
Joined: 03 Aug 2016, 14:41


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron