Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 12.04

Questions and information regarding the TeamDrive web portal, browser client and TeamDrive Agent - Fragen und Informationen zum TeamDrive Webportal, Browser-Client und TeamDrive Agent

Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 12.04

Postby etikw » 02 Nov 2014, 01:06

Teamdrive agent version 3.2.1.921 crashes on ubuntu precise (12.04) with log message

[QFatal] MainThread Cannot mix incompatible Qt library (version 0x40801) with this library (version 0x40805)


Would an older agent version (3.0.2.136 ?) using Qt 4.8.1 be an option? Are there download links for previous agent versions?

Upgrading Qt to 4.8.5 doesn't seem to be an option.

Thanks for your help.
etikw
 
Posts: 3
Joined: 02 Nov 2014, 00:41

Re: Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 1

Postby Kenneth » 03 Nov 2014, 16:13

Are you able to start TeamDrive? Is TeamDrive crashing when you are trying to choose a new location for a folder?
Kenneth
 
Posts: 1216
Joined: 29 Aug 2012, 15:11

Re: Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 1

Postby etikw » 04 Nov 2014, 13:28

Doesn't start but crashes with errors in log.
etikw
 
Posts: 3
Joined: 02 Nov 2014, 00:41

Re: Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 1

Postby Kenneth » 06 Nov 2014, 15:38

Try this update version and let us know if it fixes the problem.

http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1007/TMDR/linux-x86_64/teamdrive3-3.3.1-1007.x86_64.rpm
http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1007/TMDR/linux-x86_64/teamdrive3-3.3.1_amd64.deb
http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1007/TMDR/linux-x86_64/Install-TeamDrive-3.3.1.1007_TMDR.run
http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1006/TMDR/linux/teamdrive3-3.3.1_i386.deb
http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1006/TMDR/linux/Install-TeamDrive-3.3.1.1006_TMDR.run
http://s3download.teamdrive.net.s3.amazonaws.com:80/3.3.1006/TMDR/linux/teamdrive3-3.3.1-1006.i386.rpm

Please start Team Drive on the appropriate menu, via the global command "teamdrive3" or in the program directory "./TeamDrive". TeamDrive requires some settings that are usually not available to the TeamDrive.bin executable.
Kenneth
 
Posts: 1216
Joined: 29 Aug 2012, 15:11

Re: Agent: Incompatible Qt library 4.8.1<->4.8.5 on Ubuntu 1

Postby etikw » 14 Nov 2014, 15:14

Thanks for the updates and sorry for the late response - I will be very busy till end of next week.

I gave it a quick try. Installation worked but teamdrive stops telling there is no X session.

I would like to run a teamdrive client on an ubuntu server without X. Is teamdrive _agent_ suitable for this or is it something used for managing a teamdrive server? Sorry for my ignorance.

Maybe I can provide the required X by some VNC server.
etikw
 
Posts: 3
Joined: 02 Nov 2014, 00:41


Return to Web Client and TeamDrive Agent with Browser Client (Linux and Windows 2012 Server R2+)

Who is online

Users browsing this forum: No registered users and 1 guest