How-to: Resolving a Few Common TeamDrive 4.6.x-Linux Issues

Questions and information regarding the Linux desktop client - Fragen und Informationen zum Linux Desktop-Client

How-to: Resolving a Few Common TeamDrive 4.6.x-Linux Issues

Postby Kenneth » 16 May 2018, 09:32

Top: English
Unten: Deutsch
Kenneth
 
Posts: 1081
Joined: 29 Aug 2012, 15:11

English

Postby Kenneth » 16 May 2018, 09:33

Version 4.6.x on Linux has three small hiccups:


1. The start menu shortcut located under the path /usr/bin/teamdrive no longer starts TeamDrive, because the shortcut points to a path, which no longer exists. Please change the path the shortcut points to from:

/opt/teamdrive/teamdrive

to

/opt/teamdrive/TeamDrive.bin

Image

2. The Qt version we are currently using in TeamDrive supports High-DPI monitors. This can, however, lead to the program incorrectly identifying supported resolutions. More info regarding Qt and High-DPI can be found here: https://wiki.archlinux.org/index.php/HiDPI#Qt_5

Starting the program with

QT_SCALE_FACTOR=0.9 teamdrive

Image
Image

will allow you to scale down the resolution a bit. You should play around with the scale factor value (e.g. 0.9) and determine which scale factor works best for you.


3. On Ubuntu 18 there is a problem with a library, which results in the following error message:

symbol lookup error: /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

Other applications encounter the same issue as well: https://github.com/ValveSoftware/steam-for-linux/issues/4816#issuecomment-273339781

Setting the environment variable

LIBGL_DRI3_DISABLE=1

should remedy this issue.
Kenneth
 
Posts: 1081
Joined: 29 Aug 2012, 15:11

Deutsch

Postby Kenneth » 16 May 2018, 09:34

In der Version 4.6.x gibt es drei kleine Problemchen unter Linux:

1. Mit dem Start-Shortcut, der in /usr/bin/teamdrive liegt, startet TeamDrive nicht, da in der Datei ein falscher Verweis ist. Diesen einmal ändern von:

/opt/teamdrive/teamdrive

auf

/opt/teamdrive/TeamDrive.bin

Image

2. Die neue Qt-version, die wir benutzen, unterstützt High-DPI-Monitore. Es kann ggf. zu Problemen mit der Erkennung der unterstützten Auflösung kommen. Hier gibt es Infos zu Qt und High-DPI:

https://wiki.archlinux.org/index.php/HiDPI#Qt_5

Wenn man die Anwendung mit:

QT_SCALE_FACTOR=0.9 teamdrive

Image
Image

startet, kann man die Skalierung etwas verkleinern. Welcher Faktor für Sie passend ist, müssen Sie etwas probieren. Hier also die 0.9 mit eigenen Werten anpassen.


3. Bei Ubuntu mit der Version 18 gibt es ein Problem mit einer Library und dieser Fehlermeldung:

symbol lookup error: /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

Andere Anwendungen haben das gleiche Problem:

https://github.com/ValveSoftware/steam-for-linux/issues/4816#issuecomment-273339781

Man muss einmal die Environment Variable:

LIBGL_DRI3_DISABLE=1

setzen.
Kenneth
 
Posts: 1081
Joined: 29 Aug 2012, 15:11

Re: How-to: Resolving a Few Common TeamDrive 4.6.x-Linux Iss

Postby hoyesdomingo » 31 Oct 2018, 16:19

Hi,

I did not really understand what to do to fix the starting problem (point 3). I had the same issue as described:
symbol lookup error: /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

But: I did not know where to add the Environmental Variable. What I did then was to edit the console-command user "pesr0412" posted in this post:
https://github.com/ValveSoftware/steam-for-linux/issues/4816#issuecomment-413899646

So I edited it to

Code: Select all
LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/teamdrive


and added it into the Command field:

Image

Now, for me, it works to just start TeamDrive from the start menu. Is this what you meant one had to set the Environmental Variable?

Cheers
Domingo
hoyesdomingo
 
Posts: 1
Joined: 31 Oct 2018, 14:59

"undefined symbol" issue still unsolved in 4.6.6

Postby teamplayer » 30 Jan 2019, 12:03

As reported earlier by other users, trying to start the teamdrive client ends up with the error message:
TeamDrive.bin: symbol lookup error: /usr/lib64/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

OS: SuSE LEAP 15.0

I tried to set environment variables as recommended in earlier posts in this forum, but to no avail.

Any suggestions?
teamplayer
 
Posts: 4
Joined: 30 Jan 2019, 11:44

4.6.7: symbol lookup error: /usr/lib64/libxcb-dri3

Postby teamplayer » 05 Mar 2019, 16:10

Reported by others since long time ago its still there in 4.6.7:

./TeamDrive.bin: symbol lookup error: /usr/lib64/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

so the binary doesn't start

OS: SuSE LEAP 15
teamplayer
 
Posts: 4
Joined: 30 Jan 2019, 11:44

Re: 4.6.7: symbol lookup error: /usr/lib64/libxcb-dri3

Postby Kenneth » 12 Mar 2019, 12:10

https://forum.teamdrive.net/viewtopic.php?f=12&t=3247

I think this post may be helpful
Kenneth
 
Posts: 1081
Joined: 29 Aug 2012, 15:11

Re: 4.6.7: symbol lookup error: /usr/lib64/libxcb-dri3

Postby teamplayer » 12 Mar 2019, 16:26

Hi Kenneth,
thanks for your hint but I already knew those previous posts.
None of the referrals work, neither setting the environmet variable nore preloading the modules.
Teamplayer
teamplayer
 
Posts: 4
Joined: 30 Jan 2019, 11:44

symbol lookup error: /usr/lib64/libxcb-dri3.so.0

Postby teamplayer » 18 Mar 2019, 14:43

Reported by others since long time ago, it is still there in 4.6.7:

./TeamDrive.bin: symbol lookup error: /usr/lib64/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds

so the binary doesn't start. Setting environment variables, preloading modules etc. doesn't help.

OS: SuSE LEAP 15



@Kenneth: Please don't remove this post again before the bug is really fixed
teamplayer
 
Posts: 4
Joined: 30 Jan 2019, 11:44

Re: symbol lookup error: /usr/lib64/libxcb-dri3.so.0

Postby Kenneth » 19 Mar 2019, 11:46

@Teamplayer: The post was not removed but, instead, merged with the existing thread addressing the "symbol lookup error: /usr/lib64/libxcb-dri3.so.0" error message.

Please refrain from creating duplicates threads. I ask that you use the search function to find topics of interest and add posts to the relevant threads, if they already exist. Having multiple threads addressing the same topic leads to difficulties for support seekers when searching for a solution. Therefore, this topic will also be merged with the existing thread addressing the "symbol lookup error: /usr/lib64/libxcb-dri3.so.0" error. I ask that you please make your posts regarding this issue there.

I will also send you this message as a PM, in case you are unable to find the thread once I have merged it.

Here is a link to the existing thread: https://forum.teamdrive.net/viewtopic.php?f=12&t=3247
Kenneth
 
Posts: 1081
Joined: 29 Aug 2012, 15:11

Next

Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron